Updating Drupal 9.0 to 9.1 using Composer 2

Update Composer 1 to Composer 2

 

Update Drupal's composer.json to using Composer 2

composer require "composer/installers:^1.9"

 

composer outdated "drupal/*"

composer update drupal/core "drupal/core-*" --with-all-dependencies

vendor/bin/drush drush updatedb

 

vendor/bin/drush cache:rebuild

 

Update modules and other dependencies

composer update